Owlet later rendered jobs should be named after the job name instead of "result"
When rendering multiples scenes we have to rename the results before we can store them in the same folder. It's annoying and sometimes leads to errors. It would be great if they would be named after the job name. Also when renaming the result.png before moving them, when we close and reopen owlet marks the the jobs as not rendered.